aboutsummaryrefslogtreecommitdiffstats
path: root/setup.cfg
diff options
context:
space:
mode:
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg49
1 files changed, 46 insertions, 3 deletions
diff --git a/setup.cfg b/setup.cfg
index 6875734..2def390 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,49 @@
[wheel]
-universal = True
+universal = true
+
[flake8]
-exclude = hypervideo_dl/extractor/__init__.py,devscripts/buildserver.py,devscripts/lazy_load_template.py,devscripts/make_issue_template.py,setup.py,build,.git,venv,devscripts/create-github-release.py,devscripts/release.sh,devscripts/show-downloads-statistics.py
-ignore = E402,E501,E731,E741,W503 \ No newline at end of file
+exclude = build,venv,.tox,.git,.pytest_cache
+ignore = E402,E501,E731,E741,W503
+max_line_length = 120
+per_file_ignores =
+ devscripts/lazy_load_template.py: F401
+
+
+[autoflake]
+ignore-init-module-imports = true
+ignore-pass-after-docstring = true
+remove-all-unused-imports = true
+remove-duplicate-keys = true
+remove-unused-variables = true
+
+
+[tool:pytest]
+addopts = -ra -v --strict-markers
+markers =
+ download
+
+
+[tox:tox]
+skipsdist = true
+envlist = py{36,37,38,39,310},pypy{36,37,38,39}
+skip_missing_interpreters = true
+
+[testenv] # tox
+deps =
+ pytest
+commands = pytest {posargs:"-m not download"}
+passenv = HOME # For test_compat_expanduser
+setenv =
+ # PYTHONWARNINGS = error # Catches PIP's warnings too
+
+
+[isort]
+py_version = 37
+multi_line_output = VERTICAL_HANGING_INDENT
+line_length = 80
+reverse_relative = true
+ensure_newline_before_comments = true
+include_trailing_comma = true
+known_first_party =
+ test